Panbo

Gizmo Wisdom #1, reboot 'er!

... written for Panbo by Ben Ellison and posted on Apr 28, 2009
Gizmo_delivery_fly_bridge_cPanbo.JPG

Notice anything unusual in this photo, besides Gizmo's wonderfully spacious fly bridge (for a 37 footer) and the odd looking RAM-mounted panel (that I had already crafted for Li'l Gizmo and brought along so we'd have the PB200 output up here, and also a 25W GPS-connected DSC VHF onboard)?  Yup, the bezel is off the Raymarine C-120 and that's a screwdriver in my left hand.  Just before we reached Buzzard's Bay (above), the C-120 reported a communication error regarding its DSM 300 sounder module and we then lost all depth knowledge.  Which led to one of several lessons I'm going to start collecting under the rubric Gizmo Wisdom (or GizWis)...

GizWis #1-A:  It's good to have a back-up depth sensor/system.  We did this trip with multiple independent GPS sensors and electronic chart systems, but only one depth source, and, damn, I felt naked without it.  I did, of course, try rebooting the C120, and then checked for flaky connectors.  First I eyeballed the Airmar transducer mounted under the cockpit; then the DSM 300, acessible via that open door under the fly bridge helm; and finally the back of C120 itself, viewed by pulling the unit off the helm.  While I did find a questionable splice in the transducer cable, otherwise everything looked tight, clean, and new (which it was last year).  But -- trouble shooting having failed -- I started rethinking some of my cruise ideas, like the skinny but pretty Annisquam Canal.  Besides, the forecasts were suggesting that we'd be smart to skip the cruising and steam right through the night for home.
    Which is how we found ourselves stopping to do engine checks and switch fuel tanks off Plymouth, Massachusetts, that evening.  But when we started the Volvo again, a "diagnostic" light started flashing and the electronic engine controls wouldn't throttle beyond idle, just shift.  We tried shutting down again, switching stations, and pondering the manual...no joy.  After hanging a 4.5 knot left toward the Harbor, I called Denny Klodner.  It's great that you can cell phone a guy like Denny from several miles out these days (and he might actually answer or call back), but he didn't have any specific solutions except to "reboot" the whole system.
   Which was harder than it sounds.  There's a lot of juice flowing around Gizmo, I haven't learned the flows yet (despite the diagrams), and we had to shut down three primary battery switches and a 100 amp circuit breaker before we were confident that the Volvo control system was truly de-powered.  But damned if the engine didn't work perfectly after the reboot.  And shortly after we returned to course -- i.e. crossing the Boston shipping lanes and some more adventures -- I realized that the DSM 300 was also working fine again.  GizWis #1-B: When things get wiggly, shut everything down, completely down, and thus reboot your whole boat.

PS.  The boat's only current radar is the RL70 at the lower station below (with a 24" dome on the mast).  It's circa 2000 but worked surprisingly well when tweaked.  In this photo we're running on flat water in Muscongus Bay yesterday morning; the RL70's sea clutter filter is completely off, target expansion is on, and the gain is turned up a bit above the automatic setting.  What you're seeing at 1/8 mile scale is Gizmo's wake and a few lobster pot buoys I could actually see out the window.  I could also see coastal features over 30 miles away when we were offshore.  Pretty impressive, but this unit and its RN300 GPS companion are going on eBay unless someone here speaks up first.  Gizmo will be trying multiple new radar sets this summer, even if occasional rebooting is necessary, and I need to make space!

Gizmo_delivery_RL70_cPanbo.JPG

Comments

Good to learn you arrived safely. Major bummer that one may have to do complete reboots or suffer serious performance failure. I'd like to know how this actually happens. I had to reboot my C80 a few times when I button pressed the hell out of it and drove it crazy and she locked up.

An autopilot failure is a real bummer for short handers and this is a hard one as far as redundancy is concerned.

And yes a back up depth sensor, stand alone is never a bad idea!.

Do you think you can find the cause of the failures, or will they forever haunt you with doubt as you head out? At least you know what may get the electrons flowing again. When it's out - reboot.

Posted by: SanderO at April 29, 2009 6:59 AM | Reply

Regarding the Raymarine C-Series, I should have thought to shut off the "instrument" circuit breaker during my trouble shooting, as I suspect that just turning the C120 on and off did not de-power the DSM 300 box. I'll certainly try that if the problem ever happens again. But it may not, as so far it's only happened once in 30 plus hours of run time.

The engine problem, of course, was much more worrisome, but I'm very much hoping it too was an anomaly. The engine shut down that proceeded it was not normal; that is to say that my mate wasn't used to the sensitive electronic controls, and put her in reverse when just trying to find neutral, which caused (along with the 500rpm idle) the engine to conk out.

Another factor is that the boat's previous owner didn't have her long, and didn't use her much, and so may not have been able to pass along the fine points. Plus I haven't yet taken the time to thoroughly go over the engine manual and figure out all the power flows. But I will! The good news: Gizmo has already logged over 16,000 miles with this engine and controls.

Posted by: Ben at April 29, 2009 10:45 AM | Reply

Ben,

Hope you consider the Simrad Broadband Radar BR24 for Gizmo. Would love to have the benifit of your review. I'm considering it to replace my "short range" Furuno unit..keeping my BIG Furuno for long range needs and backup.

David

Posted by: David at April 29, 2009 10:46 AM | Reply

Do you really have to stop the boat to switch fuel tanks? There must be more to that stop.

There is something not right about having to "reboot" the entire boat. There was an old joke about the consequences of Microsoft going into the car business; how you'd have to stop, get out of the car and reboot every 60 miles. It sounds like that prophecy has come to boating, though it's probably not Microsoft's fault in this case.

Posted by: Russ at April 29, 2009 11:28 AM | Reply

re the DSM300,yes it's power is not controlled from the c120.
Always a good idea to have switches or circuit breakers.
Aalso note the c120 power switch is a"soft"switch so it doesn't really repower the c120 completely.

For that you gotta unplug or flip the breaker.

Posted by: Peter Coupland at April 29, 2009 3:53 PM | Reply

How much are you going to let the radar go for?? im in need of a simple unit for my Panga.

Posted by: T.Smith at April 29, 2009 3:54 PM | Reply

I had the same problem plaguing me for an entire run from St. Augustine to Boston a couple years ago. The connection between a C series machine and a DSM300 was lost several times a day on that trip.

I've also heard numerous other stories of C series machines losing contact with the DSM300. And Raymarine seems to knows about it too as they have replaced some DSM300s for what could possibly be a poor solder inside the network connection.

Posted by: Ethan at April 29, 2009 4:48 PM | Reply

For depth backup, just this week, I got a
DT800 NMEA 2000 Depth Transducer that fits my
Raymarine supplied housing and connects to a
Lowrance LMF-400 display. Once I take care of
cabling and mounting I will have a completely
independent backup depth sounder system.

If I end up using the LMF-400 for other purposes
I plan to disconnect it during lightning storms.

On a smaller sailboat with a failed, caulked-in,
depth transducer I tried to mount a $100
fishfinder at the bow using PVC pipe (yes,
transom mount would have worked better, but I
did not want the information delay with respect
to the keel).

Jon

Posted by: JonM at April 29, 2009 8:12 PM | Reply

Enjoy reading the blogs. Net working is in theory an ideal solution saving on individual cabling etc. But what a collective disaster when things go wrong.
The KISS principle has many merits. Anyone planning long distance cruising should consider this.

Posted by: Geoff Roberts at April 29, 2009 10:51 PM | Reply

I suppose an ideal situation is stand alone instruments which can output to a central MFD "aggregator" of data. If the MFD fails you have the stand alone units. I took this approach and the MFD is the radar. I have separate plotters and can't interface my older B&G so they are truly stand alone. It's handy to have all the data at the MFD and with software you can do some interesting "what ifs".

Posted by: SanderO at April 30, 2009 8:09 AM | Reply

Ben... if you have to reboot the whole friggin' boat, it's not a reboot, it's reboat. Sounds like you had a fine ride on a fine steed! I look forward to meeting her someday.

Posted by: Charlie at April 30, 2009 9:17 AM | Reply

I ran across this and thought you might find it useful...instructions for creating a sextant from a CD, it's case and a few other parts. So when all your powered instruments shut down, you can select an installation cd to scrap and go back to basics.
http://www.tecepe.com.br/nav/CDSextantProject.htm

Posted by: ABC at April 30, 2009 9:33 PM | Reply

Ben, I'm looking forward to reading about your tests from the new boat. I have a MFD with radar, sounder etc all networked together and I have never had to reboot my system. But then again it is a Furuno. Raymarine is not the same quality as the Raytheon or Autohelm of yester-year. It looks nice but many of the people at our club that use Raymarine complain about the same problem as you're experiencing Ben. Screens locking up and some reboot as part of their watch.

Posted by: John at May 1, 2009 4:12 AM | Reply

Ben-
Many weeks ago I had asked if you had any info on a E120 + DSM 300 combo(Vs the C series) having problems with loosing the Depth display. We have had it fixed once and working just fine for many hours after much frustration then lost it again for a short time. I shut off the system with breakers, removed the SeaTalk DSM connector from the back of the E120 and reattached it. Fired it back up and PRESTO - Depth returned. But you can tell things are going wonky if you see the strip chart hesitate and jump rather than move smoothly to the left. It'll fail shortly.

I had one reply from Raymarine asking for the SN of the Units - so something may be amiss in some production ranges. I also asked the Raymarine Mfg Rep at the 2009 Seattle Boat show. He indicated the problems can relate to DC voltage levels at the equipment but there is no known general problem. Specifically if the DSM 300 - that takes tons of Current - has a low input voltage it can become flaky. This would be related to the wiring used to distribute power. You'll have to measure voltage to the unit with the DSM 300 cover removed.

Posted by: DaveV at May 4, 2009 12:32 AM | Reply

Leave a comment